re = /(ДАНИ)(?:Л|ЛУ|ЛА|ЛОМ|ЛЕ|)
/m
str = 'ДАНИЛУ
ДАНИЛА
С ДАНИЛОМ
О ДАНИЛЕ
ДАНИЛ
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end