$re = '/(ДАНИ)(?:Л|ЛУ|ЛА|ЛОМ|ЛЕ|)
/m';
$str = 'ДАНИЛУ
ДАНИЛА
С ДАНИЛОМ
О ДАНИЛЕ
ДАНИЛ
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);