package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(ДАНИ)(?:Л|ЛУ|ЛА|ЛОМ|ЛЕ|)
`)
var str = `ДАНИЛУ
ДАНИЛА
С ДАНИЛОМ
О ДАНИЛЕ
ДАНИЛ
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}