const regex = /\b(abc)[^.]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(abc)[^.]', 'gm')
const str = `abc, abc.def`;
const subst = `yes`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);