$re = '/\b(abc)[^.]/m';
$str = 'abc, abc.def';
$subst = "yes";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;