import re
regex = re.compile(r"\b(abc)[^.]", flags=re.MULTILINE)
test_str = "abc, abc.def"
subst = "yes"
result = regex.sub(subst, test_str)
if result:
print(result)