use strict;
my $str = 'abc, abc.def';
my $regex = qr/\b(abc)[^.]/mp;
my $subst = 'yes';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";