#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?i)^"*.(.*?)|.*(?=.exe)\.\w{2,3}.([^"]+)"
Local $sString = "" & @CRLF & _
"Send('BLA.CMD "Testasdf.exe" folder\file.txt asdf123')" & @CRLF & _
"Send('{enter}')" & @CRLF & _
"ShellExecute(@ScriptDir & "\folder\file.txt")" & @CRLF & _
"" & @CRLF & _
"ShellExecute(@HomeDrive & "\Program Files\PROGRAMDIR\Program Dir\my program.exe", @ScriptDir & "\Testblabla.exe")" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")