$re = '/(?i)^"*.(.*?)|.*(?=.exe)\.\w{2,3}.([^"]+)/m';
$str = '
Send(\'BLA.CMD "Testasdf.exe" folder\\file.txt asdf123\')
Send(\'{enter}\')
ShellExecute(@ScriptDir & "\\folder\\file.txt")
ShellExecute(@HomeDrive & "\\Program Files\\PROGRAMDIR\\Program Dir\\my program.exe", @ScriptDir & "\\Testblabla.exe")
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);