using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?i)^""*.(.*?)|.*(?=.exe)\.\w{2,3}.([^""]+)";
string input = @"
Send('BLA.CMD ""Testasdf.exe"" folder\file.txt asdf123')
Send('{enter}')
ShellExecute(@ScriptDir & ""\folder\file.txt"")
ShellExecute(@HomeDrive & ""\Program Files\PROGRAMDIR\Program Dir\my program.exe"", @ScriptDir & ""\Testblabla.exe"")
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}