import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?i)^\"*.(.*?)|.*(?=.exe)\\.\\w{2,3}.([^\"]+)";
final String string = "\n"
+ "Send('BLA.CMD \"Testasdf.exe\" folder\\file.txt asdf123')\n"
+ "Send('{enter}')\n"
+ "ShellExecute(@ScriptDir & \"\\folder\\file.txt\")\n\n"
+ "ShellExecute(@HomeDrive & \"\\Program Files\\PROGRAMDIR\\Program Dir\\my program.exe\", @ScriptDir & \"\\Testblabla.exe\")\n\n\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}