using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[+-]?\d+\.\d{1,12}$";
string input = @"1.1
0
1.123456789123
a1223
0000.1111
1.abv
0.00
1.0
0.0
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}