package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[+-]?\d+\.\d{1,12}$`)
var str = `1.1
0
1.123456789123
a1223
0000.1111
1.abv
0.00
1.0
0.0
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}