$re = '/^[+-]?\d+\.\d{1,12}$/m';
$str = '1.1
0
1.123456789123
a1223
0000.1111
1.abv
0.00
1.0
0.0
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);