#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\w+\s*\w"
Local $sString = "│Арт │ Имя │Количество │Зак.цена │" & @CRLF & _
"├──────────┼───────────────────────────────────────────────┼───────┼─────────┤" & @CRLF & _
"│ │389485artFg | Двухсоставный набор из металлических оснований│ 1.00 │" & @CRLF & _
"│ │ │111 │ │" & @CRLF & _
"│ │389485artFg | Двухсоставный набор из металлических оснований│ 1.00 │" & @CRLF & _
"│ │ │111 │ │"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")