$re = '/\w+\s*\w/';
$str = '│Арт │ Имя │Количество │Зак.цена │
├──────────┼─────────────────────────────────────────────── ┼───────┼─────────┤
│ │389485artFg | Двухсоставный набор из металлических оснований│ 1.00 │
│ │ │111 │ │
│ │389485artFg | Двухсоставный набор из металлических оснований│ 1.00 │
│ │ │111 │ │';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);