import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\w+\\s*\\w";
final String string = "│Арт │ Имя │Количество │Зак.цена │\n"
+ "├──────────┼───────────────────────────────────────────────┼───────┼─────────┤\n"
+ "│ │389485artFg | Двухсоставный набор из металлических оснований│ 1.00 │\n"
+ "│ │ │111 │ │\n"
+ "│ │389485artFg | Двухсоставный набор из металлических оснований│ 1.00 │\n"
+ "│ │ │111 │ │";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}