#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\b[\x20-\x7E]*\b$"
Local $sString = "MATCH:" & @CRLF & _
"Priya@ #432" & @CRLF & _
"" & @CRLF & _
"NOT MATCH:" & @CRLF & _
"priya##23á" & @CRLF & _
"Priya@ #432 " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")