package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\b[\x20-\x7E]*\b$`)
var str = `MATCH:
Priya@ #432
NOT MATCH:
priya##23á
Priya@ #432
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}