// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\b[\x20-\x7E]*\b$").unwrap();
let string = "MATCH:
Priya@ #432
NOT MATCH:
priya##23á
Priya@ #432
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}