$re = '/^\b[\x20-\x7E]*\b$/m';
$str = 'MATCH:
Priya@ #432
NOT MATCH:
priya##23á
Priya@ #432
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);