#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<!^|;)"(?!;|$)"
Local $sString = "123123;"This is a text. These "quotes" should be matched, this one not";"text";4125;"Also no match"" & @CRLF & _
"123123;"This is a text. These "quotes" should be matched, this one not";"text";4125;"Also no match""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")