$re = '/(?<!^|;)"(?!;|$)/m';
$str = '123123;"This is a text. These "quotes" should be matched, this one not";"text";4125;"Also no match"
123123;"This is a text. These "quotes" should be matched, this one not";"text";4125;"Also no match"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);