using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!^|;)""(?!;|$)";
string input = @"123123;""This is a text. These ""quotes"" should be matched, this one not"";""text"";4125;""Also no match""
123123;""This is a text. These ""quotes"" should be matched, this one not"";""text"";4125;""Also no match""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}