re = /(?<!^|;)"(?!;|$)/m
str = '123123;"This is a text. These "quotes" should be matched, this one not";"text";4125;"Also no match"
123123;"This is a text. These "quotes" should be matched, this one not";"text";4125;"Also no match"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end