import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ">([A-zÀ-ÿ.,:?! ]{1,})<|>([ A-zÀ-ÿ.,:?!]{1,})\\n";
final String string = "<w:p w:rsidR=\"00AE2D8E\" w:rsidRPr=\"00AE2D8E\" w:rsidRDefault=\"00AE2D8E\">\n"
+ " <w:pPr>\n"
+ " <w:rPr>\n"
+ " <w:lang w:val=\"en-US\"/>\n"
+ " </w:rPr>\n"
+ " </w:pPr>\n"
+ " <w:r w:rsidRPr=\"00AE2D8E\">\n"
+ " <w:rPr>\n"
+ " <w:lang w:val=\"en-US\"/>\n"
+ " </w:rPr>\n"
+ " <w:t xml:space=\"preserve\"> Lorem ipsum dolor sit </w:t>\n"
+ " </w:r>\n"
+ " <w:proofErr w:type=\"spellStart\"/>\n"
+ " <w:r w:rsidRPr=\"00AE2D8E\">\n"
+ " <w:rPr>\n"
+ " <w:b/>\n"
+ " <w:lang w:val=\"en-US\"/>\n"
+ " </w:rPr>\n"
+ " <w:t>amet</w:t>\n"
+ " </w:r>\n"
+ " <w:proofErr w:type=\"spellEnd\"/>\n"
+ " <w:r w:rsidRPr=\"00AE2D8E\">\n"
+ " <w:rPr>\n"
+ " <w:b/>\n"
+ " <w:lang w:val=\"en-US\"/>\n"
+ " </w:rPr>\n"
+ " <w:t xml:space=\"preserve\"> </w:t>\n"
+ " </w:r>\n"
+ " <w:proofErr w:type=\"spellStart\"/>\n"
+ " <w:r w:rsidRPr=\"00AE2D8E\">\n"
+ " <w:rPr>\n"
+ " <w:b/>\n"
+ " <w:lang w:val=\"en-US\"/>\n"
+ " </w:rPr>\n"
+ " <w:t>consecteur</w:t>\n"
+ " </w:r>\n"
+ " <w:proofErr w:type=\"spellEnd\"/>\n"
+ " <w:r w:rsidRPr=\"00AE2D8E\">\n"
+ " <w:rPr>\n"
+ " <w:b/>\n"
+ " <w:lang w:val=\"en-US\"/>\n"
+ " </w:rPr>\n"
+ " <w:t>.</w:t>\n"
+ " </w:r>\n"
+ " <w:bookmarkStart w:id=\"0\" w:name=\"_GoBack\"/>\n"
+ " <w:bookmarkEnd w:id=\"0\"/>\n"
+ "</w:p>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}