# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r">([A-zÀ-ÿ.,:?! ]{1,})<|>([ A-zÀ-ÿ.,:?!]{1,})\n"
test_str = ("<w:p w:rsidR=\"00AE2D8E\" w:rsidRPr=\"00AE2D8E\" w:rsidRDefault=\"00AE2D8E\">\n"
" <w:pPr>\n"
" <w:rPr>\n"
" <w:lang w:val=\"en-US\"/>\n"
" </w:rPr>\n"
" </w:pPr>\n"
" <w:r w:rsidRPr=\"00AE2D8E\">\n"
" <w:rPr>\n"
" <w:lang w:val=\"en-US\"/>\n"
" </w:rPr>\n"
" <w:t xml:space=\"preserve\"> Lorem ipsum dolor sit </w:t>\n"
" </w:r>\n"
" <w:proofErr w:type=\"spellStart\"/>\n"
" <w:r w:rsidRPr=\"00AE2D8E\">\n"
" <w:rPr>\n"
" <w:b/>\n"
" <w:lang w:val=\"en-US\"/>\n"
" </w:rPr>\n"
" <w:t>amet</w:t>\n"
" </w:r>\n"
" <w:proofErr w:type=\"spellEnd\"/>\n"
" <w:r w:rsidRPr=\"00AE2D8E\">\n"
" <w:rPr>\n"
" <w:b/>\n"
" <w:lang w:val=\"en-US\"/>\n"
" </w:rPr>\n"
" <w:t xml:space=\"preserve\"> </w:t>\n"
" </w:r>\n"
" <w:proofErr w:type=\"spellStart\"/>\n"
" <w:r w:rsidRPr=\"00AE2D8E\">\n"
" <w:rPr>\n"
" <w:b/>\n"
" <w:lang w:val=\"en-US\"/>\n"
" </w:rPr>\n"
" <w:t>consecteur</w:t>\n"
" </w:r>\n"
" <w:proofErr w:type=\"spellEnd\"/>\n"
" <w:r w:rsidRPr=\"00AE2D8E\">\n"
" <w:rPr>\n"
" <w:b/>\n"
" <w:lang w:val=\"en-US\"/>\n"
" </w:rPr>\n"
" <w:t>.</w:t>\n"
" </w:r>\n"
" <w:bookmarkStart w:id=\"0\" w:name=\"_GoBack\"/>\n"
" <w:bookmarkEnd w:id=\"0\"/>\n"
"</w:p>")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.