re = />([A-zÀ-ÿ.,:?! ]{1,})<|>([ A-zÀ-ÿ.,:?!]{1,})\n/
str = '<w:p w:rsidR="00AE2D8E" w:rsidRPr="00AE2D8E" w:rsidRDefault="00AE2D8E">
<w:pPr>
<w:rPr>
<w:lang w:val="en-US"/>
</w:rPr>
</w:pPr>
<w:r w:rsidRPr="00AE2D8E">
<w:rPr>
<w:lang w:val="en-US"/>
</w:rPr>
<w:t xml:space="preserve"> Lorem ipsum dolor sit </w:t>
</w:r>
<w:proofErr w:type="spellStart"/>
<w:r w:rsidRPr="00AE2D8E">
<w:rPr>
<w:b/>
<w:lang w:val="en-US"/>
</w:rPr>
<w:t>amet</w:t>
</w:r>
<w:proofErr w:type="spellEnd"/>
<w:r w:rsidRPr="00AE2D8E">
<w:rPr>
<w:b/>
<w:lang w:val="en-US"/>
</w:rPr>
<w:t xml:space="preserve"> </w:t>
</w:r>
<w:proofErr w:type="spellStart"/>
<w:r w:rsidRPr="00AE2D8E">
<w:rPr>
<w:b/>
<w:lang w:val="en-US"/>
</w:rPr>
<w:t>consecteur</w:t>
</w:r>
<w:proofErr w:type="spellEnd"/>
<w:r w:rsidRPr="00AE2D8E">
<w:rPr>
<w:b/>
<w:lang w:val="en-US"/>
</w:rPr>
<w:t>.</w:t>
</w:r>
<w:bookmarkStart w:id="0" w:name="_GoBack"/>
<w:bookmarkEnd w:id="0"/>
</w:p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end