using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^while ((?=\S)[1di\W]|an|eval|nput|nt|or|pr){55}s(?1){45}n...$";
string input = @"while ord>eval:1;int,eval=int<1and(int,eval+1)or(-input(),1);i=int;ord=i*i;print'%*s'%(-i,(eval+~i+~-eval%-i*~1,eval)[eval/i&1])+'\nt'[:-1<eval%int],";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}