const regex = /^while ((?=\S)[1di\W]|an|eval|nput|nt|or|pr){55}s(?1){45}n...$/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^while ((?=\\S)[1di\\W]|an|eval|nput|nt|or|pr){55}s(?1){45}n...$', 'g')
const str = `while ord>eval:1;int,eval=int<1and(int,eval+1)or(-input(),1);i=int;ord=i*i;print'%*s'%(-i,(eval+~i+~-eval%-i*~1,eval)[eval/i&1])+'\\nt'[:-1<eval%int],`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}