use strict;
my $str = 'while ord>eval:1;int,eval=int<1and(int,eval+1)or(-input(),1);i=int;ord=i*i;print\'%*s\'%(-i,(eval+~i+~-eval%-i*~1,eval)[eval/i&1])+\'\\nt\'[:-1<eval%int],';
my $regex = qr/^while ((?=\S)[1di\W]|an|eval|nput|nt|or|pr){55}s(?1){45}n...$/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}