$re = '/^while ((?=\S)[1di\W]|an|eval|nput|nt|or|pr){55}s(?1){45}n...$/';
$str = 'while ord>eval:1;int,eval=int<1and(int,eval+1)or(-input(),1);i=int;ord=i*i;print\'%*s\'%(-i,(eval+~i+~-eval%-i*~1,eval)[eval/i&1])+\'\\nt\'[:-1<eval%int],';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);