#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)"event-title">([\w ]+)"
Local $sString = "<some_tag name="event-title">Some text 1</some-tag>" & @CRLF & _
"<some_tag name="event-title">Some text 2</some-tag>" & @CRLF & _
"<some_tag name="event-title">Some text 3</some-tag>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")