import re
regex = re.compile(r"\"event-title\">([\w ]+)", flags=re.MULTILINE)
test_str = ("<some_tag name=\"event-title\">Some text 1</some-tag>\n"
"<some_tag name=\"event-title\">Some text 2</some-tag>\n"
"<some_tag name=\"event-title\">Some text 3</some-tag>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")