re = /"event-title">([\w ]+)/m
str = '<some_tag name="event-title">Some text 1</some-tag>
<some_tag name="event-title">Some text 2</some-tag>
<some_tag name="event-title">Some text 3</some-tag>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end