import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[a-zA-Z]{5,30}\\d{0,10}";
final String string = "dksdfekpwef\n"
+ "askdkindolsiiejd12324434\n"
+ "kksdq9\n"
+ "fdfsf\n"
+ "user\n"
+ "1234";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}