// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[a-zA-Z]{5,30}\d{0,10}").unwrap();
let string = "dksdfekpwef
askdkindolsiiejd12324434
kksdq9
fdfsf
user
1234";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}