$re = '/[a-zA-Z]{5,30}\d{0,10}/';
$str = 'dksdfekpwef
askdkindolsiiejd12324434
kksdq9
fdfsf
user
1234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);