re = /[a-zA-Z]{5,30}\d{0,10}/
str = 'dksdfekpwef
askdkindolsiiejd12324434
kksdq9
fdfsf
user
1234'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end