using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:[^\W\d_]+\d|\d+[^\W\d_])[^\W_]*|[^\W\d_]+";
string substitution = @"";
string input = @"win32 backdoor guid:64664646 DNS-lookup h0lla 1234 12.356";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}