import re
regex = re.compile(r"(?:[^\W\d_]+\d|\d+[^\W\d_])[^\W_]*|[^\W\d_]+", flags=re.MULTILINE)
test_str = "win32 backdoor guid:64664646 DNS-lookup h0lla 1234 12.356"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)