// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(?:[^\W\d_]+\d|\d+[^\W\d_])[^\W_]*|[^\W\d_]+").unwrap();
let string = "win32 backdoor guid:64664646 DNS-lookup h0lla 1234 12.356";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}