$re = '/(?:[^\W\d_]+\d|\d+[^\W\d_])[^\W_]*|[^\W\d_]+/m';
$str = 'win32 backdoor guid:64664646 DNS-lookup h0lla 1234 12.356';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;