#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\[Remote IP\]:\s\[(?<remoteIp>([0-9\.]{0,}))\]"
Local $sString = "****************************************************************" & @CRLF & _
"[2020-12-31 10:07:04,967] [INFO ][c.s.d.s.activityLauncher.access] *********************[ ACCESS-END Info ]*********************" & @CRLF & _
"- [Date]: [2020-12-31 10:07:04.967]" & @CRLF & _
"- [Remote IP]: [10.30.20.20]" & @CRLF & _
"- [Correlation ID]: [03d93d63-9e42-4dac-9e0b-1252d149e297]" & @CRLF & _
"- [Trace ID]: [e7ca75e6b6d2dac0]" & @CRLF & _
"- [Span ID]: [34de12785de46a27]" & @CRLF & _
"- [Method]: [dmIndivCheck]" & @CRLF & _
"- [RESPONSE TIME]: [49ms]" & @CRLF & _
"- [Args]: [[IndivRequestParamDTO(DCOL_DATA_ID=EDP20201231100704849-MXNI_DCP_1, ACTIVITY_ID=EDP_DCOL_RESPONSE_DECISION, MODEL_UUID=fbb02026-6ace-4901-be2e-93c2d7341af6)]]" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")