$re = '/\[Remote IP\]:\s\[(?<remoteIp>([0-9\.]{0,}))\]/m';
$str = '****************************************************************
[2020-12-31 10:07:04,967] [INFO ][c.s.d.s.activityLauncher.access] *********************[ ACCESS-END Info ]*********************
- [Date]: [2020-12-31 10:07:04.967]
- [Remote IP]: [10.30.20.20]
- [Correlation ID]: [03d93d63-9e42-4dac-9e0b-1252d149e297]
- [Trace ID]: [e7ca75e6b6d2dac0]
- [Span ID]: [34de12785de46a27]
- [Method]: [dmIndivCheck]
- [RESPONSE TIME]: [49ms]
- [Args]: [[IndivRequestParamDTO(DCOL_DATA_ID=EDP20201231100704849-MXNI_DCP_1, ACTIVITY_ID=EDP_DCOL_RESPONSE_DECISION, MODEL_UUID=fbb02026-6ace-4901-be2e-93c2d7341af6)]]
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);