import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[Remote IP\\]:\\s\\[(?<remoteIp>([0-9\\.]{0,}))\\]";
final String string = "****************************************************************\n"
+ "[2020-12-31 10:07:04,967] [INFO ][c.s.d.s.activityLauncher.access] *********************[ ACCESS-END Info ]*********************\n"
+ "- [Date]: [2020-12-31 10:07:04.967]\n"
+ "- [Remote IP]: [10.30.20.20]\n"
+ "- [Correlation ID]: [03d93d63-9e42-4dac-9e0b-1252d149e297]\n"
+ "- [Trace ID]: [e7ca75e6b6d2dac0]\n"
+ "- [Span ID]: [34de12785de46a27]\n"
+ "- [Method]: [dmIndivCheck]\n"
+ "- [RESPONSE TIME]: [49ms]\n"
+ "- [Args]: [[IndivRequestParamDTO(DCOL_DATA_ID=EDP20201231100704849-MXNI_DCP_1, ACTIVITY_ID=EDP_DCOL_RESPONSE_DECISION, MODEL_UUID=fbb02026-6ace-4901-be2e-93c2d7341af6)]]\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}