# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^( *)(?!# console)((console\.log)+.*)$/\/\/$2/img;t' <<< "console.log(22);
//console.log('this is:', result)
//console.log
console.log
console.log
console.log
console.log
console.log
console.log
console.log"