use strict;
my $str = 'console.log(22);
//console.log(\'this is:\', result)
//console.log
console.log
console.log
console.log
console.log
console.log
console.log
console.log';
my $regex = qr/^( *)(?!# console)((console\.log)+.*)$/imp;
my $subst = '//$2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";