re = /^( *)(?!# console)((console\.log)+.*)$/im
str = 'console.log(22);
//console.log(\'this is:\', result)
//console.log
console.log
console.log
console.log
console.log
console.log
console.log
console.log'
subst = '//$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result