#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?:Ahmet|[Aa](?:hmetlii))\b"
Local $sString = "Ahmetlii OK" & @CRLF & _
"ahmetlii OK" & @CRLF & _
"Ahmet OK, not preferred but no problem" & @CRLF & _
"ahmet Definitely not (use uppercase in first letter) "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")